const regex = new RegExp('def\\s+.+\\:\\n(\\s+)\\"\\"\\"', '')
const str = `def foo(bar, k=1):
"""asdfasdf
asdfasdf
sf123
"""`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}