$re = '/def\s+.+\:\n(\s+)\"\"\"/';
$str = 'def foo(bar, k=1):
"""asdfasdf
asdfasdf
sf123
"""';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);