re = /def\s+.+\:\n(\s+)\"\"\"/
str = 'def foo(bar, k=1):
"""asdfasdf
asdfasdf
sf123
"""'
# Print the match result
str.match(re) do |match|
puts match.to_s
end