import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">\\{\\d+\\}<";
final String string = "<Financials>\n"
+ " <IncomeStatement>\n"
+ " <Revenue>{0}</Revenue>\n"
+ " <OperatingIncome>{1}</OperatingIncome>\n"
+ " <NetIncome>{2}</NetIncome>\n"
+ " <BasicEPS>{3}</BasicEPS>\n"
+ " <AvgSharesOutstand>{4}</AvgSharesOutstand>\n"
+ " </IncomeStatement>\n"
+ " <BalanceSheet>\n"
+ " <CurrentAssets>{5}</CurrentAssets>\n"
+ " <NonCurrentAssets>{6}</NonCurrentAssets>\n"
+ " <TotalAssets>{7}</TotalAssets>\n"
+ " <CurrentLiabilities>{8}</CurrentLiabilities>\n"
+ " <TotalLiabilities>{9}</TotalLiabilities>\n"
+ " <TotalEquity>{10}</TotalEquity>\n"
+ " </BalanceSheet>\n"
+ " <CashFlow>\n"
+ " <OperatingCashFlow>{11}</OperatingCashFlow>\n"
+ " <CapitalExpenditure>{12}</CapitalExpenditure>\n"
+ " <FreeCashFlow>{13}</FreeCashFlow>\n"
+ " </CashFlow>\n"
+ "</Financials>";
final String subst = "><";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}