using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#{3}([^#]+)#{3}";
string input = @"dsad###hi###vdkv324da###dog###fs
a ### b ### c ### d ### e ###";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}