$re = '/#{3}([^#]+)#{3}/';
$str = 'dsad###hi###vdkv324da###dog###fs
a ### b ### c ### d ### e ###';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);