re = /#{3}([^#]+)#{3}/
str = 'dsad###hi###vdkv324da###dog###fs
a ### b ### c ### d ### e ###'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end