const regex = /(?<year>\d{4})-(?<month>[01][0-9])-(?<day>[0123][0-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<year>\\d{4})-(?<month>[01][0-9])-(?<day>[0123][0-9])', 'gm')
const str = `2018-10-18
2018-1-1
2018-12-31
2018-01-01
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}