// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<year>\d{4})-(?<month>[01][0-9])-(?<day>[0123][0-9])").unwrap();
let string = "2018-10-18
2018-1-1
2018-12-31
2018-01-01
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}