using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""[^\""]*\""|[^,]+";
string input = @"sunil,""foo, bar"",""abc,xyz"",anil tiwari,""akhilesh,sun"", ""first,second,third""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}