package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"[^\"]*\"|[^,]+`)
var str = `sunil,"foo, bar","abc,xyz",anil tiwari,"akhilesh,sun", "first,second,third"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}