#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\S+)\s*=\s*([']|[\"])([\W\w]*?)\2"
Local $sString = "<div title="You're" data-type=' She said "ok" '>Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div class=" e ">Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div class=" e ">Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div class=" e fg h ">Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div class=" e fg h ">Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div class="e">Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div class="e fg h">Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div class="e fg h">Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div data-type="!#$%)?¡]><[;:_}{-.,">Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div data-type="!#$%&()*+,-./:;?@[\]^_`{|}~¡¢£¤¥¦§¨©ª«¬®¯°±²³´µ¶·¸¹º»¼½¾¿ÀÁÂÃÄÅÆÇÈÉÊËÌÍÎÏÐÑÒÓÔÕÖרÙÚÛÜÝÞßàáâãäåæçèéêëìíîïðñòóôõö÷øùúûüýþÿ">Hello</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<div id="a" class='b'>Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div data-type=" c " title = "d">Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div data-type="!#$%)?¡][;:_}{-.,">Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div id="a" class='b'>H</div><div id='1' class="2">W</div>" & @CRLF & _
"" & @CRLF & _
"<div id="a" class="b" title="cd" data-1=".javascript(this)" style="">Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div id='a' class='b' title='cd' data-1='javascript(this.tile)' style=''>Hello</div>" & @CRLF & _
"" & @CRLF & _
"<div id="Mine" class="red header big-font" data-type=" header " title = "a_b">Hello</div><article id="hello" class="should-not-capture">world</article>" & @CRLF & _
"" & @CRLF & _
"<div id='Mine' class='red header big-font' data-type=' header ' title = 'a_b'>Hello</div><article id='hello' class='should-not-capture'>world</article>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")