# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\S+)\s*=\s*([']|[\"])([\W\w]*?)\2"
test_str = ("<div title=\"You're\" data-type=' She said \"ok\" '>Hello</div>\n\n"
"<div class=\" e \">Hello</div>\n\n"
"<div class=\" e \">Hello</div>\n\n"
"<div class=\" e fg h \">Hello</div>\n\n"
"<div class=\" e fg h \">Hello</div>\n\n"
"<div class=\"e\">Hello</div>\n\n"
"<div class=\"e fg h\">Hello</div>\n\n"
"<div class=\"e fg h\">Hello</div>\n\n"
"<div data-type=\"!#$%)?¡]><[;:_}{-.,\">Hello</div>\n\n"
"<div data-type=\"!#$%&()*+,-./:;?@[\\]^_`{|}~¡¢£¤¥¦§¨©ª«¬®¯°±²³´µ¶·¸¹º»¼½¾¿ÀÁÂÃÄÅÆÇÈÉÊËÌÍÎÏÐÑÒÓÔÕÖרÙÚÛÜÝÞßàáâãäåæçèéêëìíîïðñòóôõö÷øùúûüýþÿ\">Hello</div>\n\n\n\n\n\n"
"<div id=\"a\" class='b'>Hello</div>\n\n"
"<div data-type=\" c \" title = \"d\">Hello</div>\n\n"
"<div data-type=\"!#$%)?¡][;:_}{-.,\">Hello</div>\n\n"
"<div id=\"a\" class='b'>H</div><div id='1' class=\"2\">W</div>\n\n"
"<div id=\"a\" class=\"b\" title=\"cd\" data-1=\".javascript(this)\" style=\"\">Hello</div>\n\n"
"<div id='a' class='b' title='cd' data-1='javascript(this.tile)' style=''>Hello</div>\n\n"
"<div id=\"Mine\" class=\"red header big-font\" data-type=\" header \" title = \"a_b\">Hello</div><article id=\"hello\" class=\"should-not-capture\">world</article>\n\n"
"<div id='Mine' class='red header big-font' data-type=' header ' title = 'a_b'>Hello</div><article id='hello' class='should-not-capture'>world</article>\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.