use strict;
my $str = '<div title="You\'re" data-type=\' She said "ok" \'>Hello</div>
<div class=" e ">Hello</div>
<div class=" e ">Hello</div>
<div class=" e fg h ">Hello</div>
<div class=" e fg h ">Hello</div>
<div class="e">Hello</div>
<div class="e fg h">Hello</div>
<div class="e fg h">Hello</div>
<div data-type="!#$%)?¡]><[;:_}{-.,">Hello</div>
<div data-type="!#$%&()*+,-./:;?@[\\]^_`{|}~¡¢£¤¥¦§¨©ª«¬®¯°±²³´µ¶·¸¹º»¼½¾¿ÀÁÂÃÄÅÆÇÈÉÊËÌÍÎÏÐÑÒÓÔÕÖרÙÚÛÜÝÞßàáâãäåæçèéêëìíîïðñòóôõö÷øùúûüýþÿ">Hello</div>
<div id="a" class=\'b\'>Hello</div>
<div data-type=" c " title = "d">Hello</div>
<div data-type="!#$%)?¡][;:_}{-.,">Hello</div>
<div id="a" class=\'b\'>H</div><div id=\'1\' class="2">W</div>
<div id="a" class="b" title="cd" data-1=".javascript(this)" style="">Hello</div>
<div id=\'a\' class=\'b\' title=\'cd\' data-1=\'javascript(this.tile)\' style=\'\'>Hello</div>
<div id="Mine" class="red header big-font" data-type=" header " title = "a_b">Hello</div><article id="hello" class="should-not-capture">world</article>
<div id=\'Mine\' class=\'red header big-font\' data-type=\' header \' title = \'a_b\'>Hello</div><article id=\'hello\' class=\'should-not-capture\'>world</article>
';
my $regex = qr/(\S+)\s*=\s*([']|[\"])([\W\w]*?)\2/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}