using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^/]+?(?:\"".*?\""|'.*?'|.*?)*?>";
string input = @"<div title=""a>b=c<d"" data-type='a>b=c<d'>Hello</div><span style=""color: >=<red"">Nothing</span>
<article title=""a>b=c<d"" data-type='a>b=c<d'>Hello</article>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}