import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^/]+?(?:\\\".*?\\\"|'.*?'|.*?)*?>";
final String string = "<div title=\"a>b=c<d\" data-type='a>b=c<d'>Hello</div><span style=\"color: >=<red\">Nothing</span>\n\n"
+ "<article title=\"a>b=c<d\" data-type='a>b=c<d'>Hello</article>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}