re = /<[^\/]+?(?:\".*?\"|'.*?'|.*?)*?>/
str = '<div title="a>b=c<d" data-type=\'a>b=c<d\'>Hello</div><span style="color: >=<red">Nothing</span>
<article title="a>b=c<d" data-type=\'a>b=c<d\'>Hello</article>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end