import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S+)\\s*=\\s*[\\\"']?((?:.(?![\\\"']?\\s+(?:\\S+)=|[>\\\"']))?[^\\\"']*)[\\\"']?";
final String string = "<div id=\"a\" class=\"b\" title=\"cd\" data-1=\".javascript(this)\" style=\"\">Hello</div>\n"
+ "<div id='a' class='b' title='cd' data-1='.javascript(this)' style=''>Hello</div>\n"
+ "<div id=\"Mine\" class=\"red header big-font\" data-type=\" header \" title = \"a_b\">Hello</div><article id=\"hello\" class=\"should-not-capture\">world</article>\n"
+ "<div id='Mine' class='red header big-font' data-type=' header ' title = 'a_b'>Hello</div><article id='hello' class='should-not-capture'>world</article>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}