$re = '/(\S+)\s*=\s*[\"\']?((?:.(?![\"\']?\s+(?:\S+)=|[>\"\']))?[^\"\']*)[\"\']?/';
$str = '<div id="a" class="b" title="cd" data-1=".javascript(this)" style="">Hello</div>
<div id=\'a\' class=\'b\' title=\'cd\' data-1=\'.javascript(this)\' style=\'\'>Hello</div>
<div id="Mine" class="red header big-font" data-type=" header " title = "a_b">Hello</div><article id="hello" class="should-not-capture">world</article>
<div id=\'Mine\' class=\'red header big-font\' data-type=\' header \' title = \'a_b\'>Hello</div><article id=\'hello\' class=\'should-not-capture\'>world</article>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);