use strict;
my $str = '<div id="a" class="b" title="cd" data-1=".javascript(this)" style="">Hello</div>
<div id=\'a\' class=\'b\' title=\'cd\' data-1=\'.javascript(this)\' style=\'\'>Hello</div>
<div id="Mine" class="red header big-font" data-type=" header " title = "a_b">Hello</div><article id="hello" class="should-not-capture">world</article>
<div id=\'Mine\' class=\'red header big-font\' data-type=\' header \' title = \'a_b\'>Hello</div><article id=\'hello\' class=\'should-not-capture\'>world</article>';
my $regex = qr/(\S+)\s*=\s*[\"']?((?:.(?![\"']?\s+(?:\S+)=|[>\"']))?[^\"']*)[\"']?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}