import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"DataType\\\",\\\"(?:Count|Net)\\\"\\n((((?<Location>\\\"[^\\\"]*\\\"),(?<Unknown>\\\"[^\\\"]*\\\"),(?<Var1>\\\"[^\\\"]*\\\"),(?<Var2>\\\"[^\\\"]*\\\"),(?<Var3>\\\"[^\\\"]*\\\"))\\n)*)";
final String string = "\"Date\",\"dd/mm/yyyy\"\n"
+ "\"ExpirationDate\",\"dd/mm/yyyy\"\n\n"
+ "\"DataType\",\"Count\"\n"
+ "\"Location\",\"Unknown\",\"Variable1\",\"Variable2\",\"Variable3\"\n"
+ "\"A(Loc3, Loc4)\",\"Unknown\",\"5656\",\"787\",\"42\"\n"
+ "\"A(Loc5, Loc6)\",\"Unknown\",\"25\",\"878\",\"921\"\n\n"
+ "\"DataType\",\"Net\"\n"
+ "\"Location\",\"Unknown\",\"Variable1\",\"Variable2\",\"Variable3\"\n"
+ "\"A(Loc3, Loc4)\",\"Unknown\",\"5656\",\"787\",\"42\"\n"
+ "\"A(Loc5, Loc6)\",\"Unknown\",\"25\",\"878\",\"921\"";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}