$re = '/\"DataType\",\"(?:Count|Net)\"\n((((?<Location>\"[^\"]*\"),(?<Unknown>\"[^\"]*\"),(?<Var1>\"[^\"]*\"),(?<Var2>\"[^\"]*\"),(?<Var3>\"[^\"]*\"))\n)*)/s';
$str = '"Date","dd/mm/yyyy"
"ExpirationDate","dd/mm/yyyy"
"DataType","Count"
"Location","Unknown","Variable1","Variable2","Variable3"
"A(Loc3, Loc4)","Unknown","5656","787","42"
"A(Loc5, Loc6)","Unknown","25","878","921"
"DataType","Net"
"Location","Unknown","Variable1","Variable2","Variable3"
"A(Loc3, Loc4)","Unknown","5656","787","42"
"A(Loc5, Loc6)","Unknown","25","878","921"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);