// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)\"DataType\",\"(?:Count|Net)\"\n((((?<Location>\"[^\"]*\"),(?<Unknown>\"[^\"]*\"),(?<Var1>\"[^\"]*\"),(?<Var2>\"[^\"]*\"),(?<Var3>\"[^\"]*\"))\n)*)"#).unwrap();
let string = "\"Date\",\"dd/mm/yyyy\"
\"ExpirationDate\",\"dd/mm/yyyy\"
\"DataType\",\"Count\"
\"Location\",\"Unknown\",\"Variable1\",\"Variable2\",\"Variable3\"
\"A(Loc3, Loc4)\",\"Unknown\",\"5656\",\"787\",\"42\"
\"A(Loc5, Loc6)\",\"Unknown\",\"25\",\"878\",\"921\"
\"DataType\",\"Net\"
\"Location\",\"Unknown\",\"Variable1\",\"Variable2\",\"Variable3\"
\"A(Loc3, Loc4)\",\"Unknown\",\"5656\",\"787\",\"42\"
\"A(Loc5, Loc6)\",\"Unknown\",\"25\",\"878\",\"921\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}