package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:0(?<rx>\d{1,6})|(?<rx>\d{1,7}))`)
var str = `02345678901235567356746
12345678901235567356746
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}