re = /^(?:0(?<rx>\d{1,6})|(?<rx>\d{1,7}))/m
str = '02345678901235567356746
12345678901235567356746
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end