$re = '/^(?:0(?<rx>\d{1,6})|(?<rx>\d{1,7}))/mJ';
$str = '02345678901235567356746
12345678901235567356746
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);