using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*pos_start=(\d+).*end_position=(\d+).*log_type=(\d+).*length=(\d+).*block_id=(\d+).*block_position=(\d+).*";
string input = @"<log pos_start=""40652288"" end_position=""40689664"" log_type=""1"" length=""37376"" block_id=""4024"" block_position=""18""/>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}