import re
regex = re.compile(r".*pos_start=(\d+).*end_position=(\d+).*log_type=(\d+).*length=(\d+).*block_id=(\d+).*block_position=(\d+).*")
test_str = "<log pos_start=\"40652288\" end_position=\"40689664\" log_type=\"1\" length=\"37376\" block_id=\"4024\" block_position=\"18\"/>"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")