package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:DE|AT)(?: ?[0-9]){18}(?:(?: ?[0-9]){2})?\b`)
var str = `################## Germany IBAN ##################
DE89 3704 0044 0532 0130 00
DE59290501010001149590
DE62500105179628448387
DE55500105172374652131
DE50500105176152274153
IBAN: DE59290501010001149590
DE 0712 3412 3412 3412 3412
DE07 1234 1234 1234 1234 12
DE07 1234 1234 1234 123412
Mashine friendly DE07123412341234123412 style
This format DE07 1234 1234 1234 1234 12 is given by DIN
Human DE07 1234 1234 1234 123412 readable
Not good DE07 12341234 1234123412 readable
################## Austrian IBAN ##################
AT61 1904 3002 3457 3201
AT59290501010001149590
AT62500105179628448387
AT55500105172374652131
AT50500105176152274153
AT 0712 3412 3412 3412 3412
AT07 1234 1234 1234 1234 12
AT07 1234 1234 1234 123412
Mashine friendly AT07123412341234123412 style
This format AT07 1234 1234 1234 1234 12 is given by DIN
Human AT07 1234 1234 1234 123412 readable
Not good AT07 12341234 1234123412 readable
################## Not Valid IBAN ##################
USt-IdNr.: DE310453183
eingetragen
Tax number: DE310453183
eingetragen
Tax number: DE310453183eingetragen
Tax number: AT310453183introduce
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}