# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:DE|AT)(?: ?[0-9]){18}(?:(?: ?[0-9]){2})?\b"
test_str = ("################## Germany IBAN ##################\n"
"DE89 3704 0044 0532 0130 00\n"
"DE59290501010001149590\n"
"DE62500105179628448387\n"
"DE55500105172374652131\n"
"DE50500105176152274153\n"
"IBAN: DE59290501010001149590\n\n\n"
"DE 0712 3412 3412 3412 3412\n"
"DE07 1234 1234 1234 1234 12\n"
"DE07 1234 1234 1234 123412\n\n"
"Mashine friendly DE07123412341234123412 style\n"
"This format DE07 1234 1234 1234 1234 12 is given by DIN\n"
"Human DE07 1234 1234 1234 123412 readable\n"
"Not good DE07 12341234 1234123412 readable\n\n"
"################## Austrian IBAN ##################\n"
"AT61 1904 3002 3457 3201\n"
"AT59290501010001149590\n"
"AT62500105179628448387\n"
"AT55500105172374652131\n"
"AT50500105176152274153\n\n"
"AT 0712 3412 3412 3412 3412\n"
"AT07 1234 1234 1234 1234 12\n"
"AT07 1234 1234 1234 123412\n\n"
"Mashine friendly AT07123412341234123412 style\n"
"This format AT07 1234 1234 1234 1234 12 is given by DIN\n"
"Human AT07 1234 1234 1234 123412 readable\n"
"Not good AT07 12341234 1234123412 readable\n\n"
"################## Not Valid IBAN ##################\n"
"USt-IdNr.: DE310453183\n"
"eingetragen \n\n"
"Tax number: DE310453183\n"
"eingetragen\n\n"
"Tax number: DE310453183eingetragen\n\n"
"Tax number: AT310453183introduce\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.