import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:DE|AT)(?: ?[0-9]){18}(?:(?: ?[0-9]){2})?\\b";
final String string = "################## Germany IBAN ##################\n"
+ "DE89 3704 0044 0532 0130 00\n"
+ "DE59290501010001149590\n"
+ "DE62500105179628448387\n"
+ "DE55500105172374652131\n"
+ "DE50500105176152274153\n"
+ "IBAN: DE59290501010001149590\n\n\n"
+ "DE 0712 3412 3412 3412 3412\n"
+ "DE07 1234 1234 1234 1234 12\n"
+ "DE07 1234 1234 1234 123412\n\n"
+ "Mashine friendly DE07123412341234123412 style\n"
+ "This format DE07 1234 1234 1234 1234 12 is given by DIN\n"
+ "Human DE07 1234 1234 1234 123412 readable\n"
+ "Not good DE07 12341234 1234123412 readable\n\n"
+ "################## Austrian IBAN ##################\n"
+ "AT61 1904 3002 3457 3201\n"
+ "AT59290501010001149590\n"
+ "AT62500105179628448387\n"
+ "AT55500105172374652131\n"
+ "AT50500105176152274153\n\n"
+ "AT 0712 3412 3412 3412 3412\n"
+ "AT07 1234 1234 1234 1234 12\n"
+ "AT07 1234 1234 1234 123412\n\n"
+ "Mashine friendly AT07123412341234123412 style\n"
+ "This format AT07 1234 1234 1234 1234 12 is given by DIN\n"
+ "Human AT07 1234 1234 1234 123412 readable\n"
+ "Not good AT07 12341234 1234123412 readable\n\n"
+ "################## Not Valid IBAN ##################\n"
+ "USt-IdNr.: DE310453183\n"
+ "eingetragen \n\n"
+ "Tax number: DE310453183\n"
+ "eingetragen\n\n"
+ "Tax number: DE310453183eingetragen\n\n"
+ "Tax number: AT310453183introduce\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}