# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/({\n\s*)(?:[^}{]*)(\n\s*{)/\1 \2/gim;t' <<< "
{
\"origin\" \"887 -100 128\"
\"texture\" \"{gargstomp\"
\"classname\" \"infodecal\"
}
"