using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({\n\s*)(?:[^}{]*)(\n\s*{)";
string substitution = @"\1 \2";
string input = @"
{
""origin"" ""887 -100 128""
""texture"" ""{gargstomp""
""classname"" ""infodecal""
}
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}