using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"add\((.+?)\)";
string input = @"add(9090@localhost,7070@moss.labs.eait.uq.edu.au)
add()
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}