re = /add\((.+?)\)/
str = 'add(9090@localhost,7070@moss.labs.eait.uq.edu.au)
add()
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end