$re = '/add\((.+?)\)/';
$str = 'add(9090@localhost,7070@moss.labs.eait.uq.edu.au)
add()
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);