# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.+returned by.+ for ([0-9]+).*/$1/gm;t' <<< "Greg Zuerlein kicks off 65 yards returned by Jaydon Mickens for 20 yards (tackle by Jayron Kearse)"