const regex = /^.+returned by.+ for ([0-9]+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.+returned by.+ for ([0-9]+).*', 'gm')
const str = `Greg Zuerlein kicks off 65 yards returned by Jaydon Mickens for 20 yards (tackle by Jayron Kearse)`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);