$re = '/^.+returned by.+ for ([0-9]+).*/m';
$str = 'Greg Zuerlein kicks off 65 yards returned by Jaydon Mickens for 20 yards (tackle by Jayron Kearse)';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;