package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([a-zA-Z.0-9_]+)[@]([a-zA-Z0-9_]+)([.][a-zA-Z0-9_]+){1,2}$`)
var str = `i.l.celine@live.com.ffr
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}