$re = '/^([a-zA-Z.0-9_]+)[@]([a-zA-Z0-9_]+)([.][a-zA-Z0-9_]+){1,2}$/';
$str = 'i.l.celine@live.com.ffr
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);