re = /^([a-zA-Z.0-9_]+)[@]([a-zA-Z0-9_]+)([.][a-zA-Z0-9_]+){1,2}$/
str = 'i.l.celine@live.com.ffr
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end