#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?msi)(?(?=\/.?)|({if \$var3}).*?)*(?={\/if})"
Local $sString = "{if $var1}" & @CRLF & _
" {if $var2}" & @CRLF & _
" {if $var3} " & @CRLF & _
" text *(&@$@!/\#<?>~`.,+-_ " & @CRLF & _
" {/if}" & @CRLF & _
" {/if}" & @CRLF & _
" {if $var4}" & @CRLF & _
" any symbols" & @CRLF & _
" {elseif $var5}" & @CRLF & _
" text" & @CRLF & _
" {else} " & @CRLF & _
" {if $var6}{/if}" & @CRLF & _
" {/if}" & @CRLF & _
" {if $var7}{/if}" & @CRLF & _
"{else}" & @CRLF & _
" text and symbols *(&@$$@!" & @CRLF & _
"{/if}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")