re = /(?(?=\/.?)|({if \$var3}).*?)*(?={\/if})/mi
str = '{if $var1}
{if $var2}
{if $var3}
text *(&@$@!/\\#<?>~`.,+-_
{/if}
{/if}
{if $var4}
any symbols
{elseif $var5}
text
{else}
{if $var6}{/if}
{/if}
{if $var7}{/if}
{else}
text and symbols *(&@$$@!
{/if}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end