using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(?=\/.?)|({if \$var3}).*?)*(?={\/if})";
string input = @"{if $var1}
{if $var2}
{if $var3}
text *(&@$@!/\#<?>~`.,+-_
{/if}
{/if}
{if $var4}
any symbols
{elseif $var5}
text
{else}
{if $var6}{/if}
{/if}
{if $var7}{/if}
{else}
text and symbols *(&@$$@!
{/if}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}