package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)({[^}]*})\s*[^{}]*\s*{/if}`)
var str = `{if $var1}
{if $var2}
{if $var3}
text *(&@$@!/\#<?>~\`.,+-_
{/if}
{/if}
{if $var4}
any symbols
{elseif $var5}
text
{else}
{if $var6}{/if}
{/if}
{if $var7}{/if}
{else}
text and symbols *(&@$$@!
{/if}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}