$re = '~({[^}]*})\s*[^{}]*\s*{/if}~i';
$str = '{if $var1}
{if $var2}
{if $var3}
text *(&@$@!/\\#<?>~`.,+-_
{/if}
{/if}
{if $var4}
any symbols
{elseif $var5}
text
{else}
{if $var6}{/if}
{/if}
{if $var7}{/if}
{else}
text and symbols *(&@$$@!
{/if}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);