// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)({[^}]*})\s*[^{}]*\s*{/if}").unwrap();
let string = "{if $var1}
{if $var2}
{if $var3}
text *(&@$@!/\\#<?>~`.,+-_
{/if}
{/if}
{if $var4}
any symbols
{elseif $var5}
text
{else}
{if $var6}{/if}
{/if}
{if $var7}{/if}
{else}
text and symbols *(&@$$@!
{/if}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}