const regex = /^(\/[A-z0-9\.\-\_]+)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\\/[A-z0-9\\.\\-\\_]+)+', 'gm')
const str = `play_arrow
April 21, 2023 10:00 AM insert_drive_file alasjsw
/home/alasjsw/domains/alsgrup.com.tr/public_html/adminer.php
SMW-BLKH-1980431-php.bkdr.db Infected
remove_red_eye
visibility_off
play_arrow
April 21, 2023 10:34 AM insert_drive_file olymvxl
/home/olymvxl/domains/olymposyacht.com/public_html/wp-config.php
SMW-INJ-20808-php.tool.upld-0 Infected
remove_red_eye
visibility_off
play_arrow
April 21, 2023 10:34 AM insert_drive_file olymvxl
/home/olymvxl/domains/olymposyacht.com/public_html/wp-content/uploads/2021/01/lang-walker-plugin.php
SMW-INJ-22095-php.bkdr.drpr-0 Infected
remove_red_eye
visibility_off
play_arrow`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}