$re = '/"([^"]+)"|\s+/';
$str = '"reference is" to ser?? test*';
$subst = "\1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;